Welcome
Welcome to the CyberPad help file.

CyberPad was made to allow people to play 2 player PlayStation™ games against each other across the internet or in a LAN.

CyberPad provide a special NetPlay-API which is applied to the PSEmu Pro API for GPU-, SPU-, PAD- and CDR-plugin functions. Currently only ePSXe support these special API-functions, but hopefully soon other emu's support them too.

CyberPad (Kaillera-based) uses, like the name says, Kaillera as communication platform to take advantage of the large Kaillera network, which has servers about anywhere in the world already.

For more informations about Kaillera, check out http://www.kaillera.com.
Copyright © 2001-2002 by Jens Duttke


Getting Started
  1. Extract the 'kailleraclient.dll' from the zip file to your ePSXe-directory (NOT the plugin directory)

  2. Extract the 'cpka.dll' in the PLUGINS-Directory.

  3. Start ePSXe and select the CyberPad plugin in the Netplay-Configuration window in ePSXe.

  4. The CyberPad plugin don't need to get configured, so click on OK.

  5. Write down your SPU (GPU and CDR) settings.

  6. Start the game using 'Run ISO' or 'Run CDROM'.

  7. Find an opponent in the Kaillera network, who use the same game.

  8. Make sure he use the same SPU (GPU and CDR)-Plugin and use the same SPU settings.
    (If you both use different settings, close the emulator, change the settings, and start it again.)

  9. Start the emulation using the 'Start game'-button in Kaillera.
For further informations on how to use Kaillera, check the Kaillera website.


System Requirements
CyberPad requires a internet connection (atleast a 56k modem) or LAN.

Furthermore you will need ePSXe 1.4.0 or higher and a 32-bit Windows operating system (Windows 95 and higher).
The plugin has been tested on Windows 2000 using ePSXe 1.5.1.

The Cyberpad plugin was compiled using the Microsoft Macro Assember 6.15.8803.
You do NOT need any runtime libraries to run it, but if you have some, do not delete them.


Legal Things
CyberPad is a copyright © 2001-2002 Jens Duttke.

PlayStation is a registered trademark of Sony Computer Entertainment, Inc. "Sony" is a registered trademark for the Sony Corporation.

Kaillera was developed by Christophe Thibault.
All other trademarks are property of their respective holders.

If you have problems while using the CyberPad, please contact me BEFORE you contact the emulator developers, the developer of Kaillera or the game developers.

I don't take any warranty for damage caused to your PC. Use it at your own risk!


Contact
If Kaillera show as game name just "Unknown game (...) (.......)". Please send me a e-mail and tell me the code in the second parenthesis (that should be something like SLUS-12345) and the real game name.

For sure, if you have any other ideas, questions or CyberPad-related-problems, you can mail me too.

You can mail to me in german and english. Mails in other languages will be ignored.

Or chat with me in EFnet , in the channels #cyberpad, #emucheater or #epsxe using mIRC or any other irc client.


Version History (Kaillera-Based Plugin)
These are all versions since the first release of the Kaillera-based version of the CyberPad plugin.

Version 1.3 beta
  • A "Out Of Sync" warning will be shown in the GPU, if the game is ... right ... out of sync. :-)
    (This is again some sort of "hack", because the current NET-Plugin-Interface does not support such a feature; it will only work if CyberPad detected your ePSXe version correctly. If ePSXe crash while using this new version, it could be most likely related to this "hack", so please mail me, if this happens.
    You will also need a GPU Plugin which support to show the SaveState-Pictures (like Pete's or Lewpy's GPU-Plugin))
    Sometimes this message flicker for one frame, this can happen sometimes and is not "important", but if it happens too often, the game is most likely out of sync.
  • 27 new game names are added to the internal game-name-database
Version 1.2 beta
  • Bug fixed, which force Kaillera to crash after closing the emulator (or does it still crash ?)
  • Chat while playing works again (didn't worked in 1.1)
  • Some more games are added to the game database (9 to be exact)
Version 1.1 beta
  • It uses a "hack" to detect the game name (works only in ePSXe 1.5.2, 1.5.1, 1.5.0 and 1.4.0 using the 'Run CDROM' and 'Run ISO' function)
  • Some small optimizations
Version 1.0 beta
  • The first release the Kaillera-based CyberPad plugin


Frequently Asked Questions
How can I improve my 'ping'-speed ?
  • Stop all your downloads in background (like mp3's, videos or psx-games :-P ).
  • If you are using a software-firewall like ZoneAlarm, you could close or disable it. (Do it at your own risk, but it works)
Can I play with the US version of my game against someone with the PAL version ?
    No, both sides need to use exactly the same version of the game.
    For example Gran Turismo 2 has a v1.0 and v1.1, which won't work together. You also won't be able to play with the NTSC version of the game against someone with the PAL version - neither will you be able to play with a german PAL game against a french version.
The game is not sync on both computers. Why that ?
    Most likely it is a problem with the SPU Plugin. Compare the settings of the Plugin with the settings of your opponent and if possible disable Timing-Stuff and XA-Sound. If that doesn't help, check the CDR and GPU settings too.
    If you found the problem, please mail me, so that I can find a solution to change this settings automatically in the next version.
The game window closed without any reason. Why that ?
    Your opponent switched in the pause mode (he pressed ESC). And your ePSXe do that too.
    You will have to restart the game, and kick your opponents ass. :-P
I am poor player. Can i use [pec] to win against my opponent ?
    No. If only one player cheat the game will loose the sync.
    If you really want to use [pec], both players need to use exactly the same codes and the same code-refresh.


Known Bugs & Issues
First of all, the current versions of CyberPad are just beta releases, to get some response from the users, to see if it's worth to resume this version of the plugin.
There are some known bugs and issues which need to be fixed and added in this CyberPad plugin version, but also in ePSXe and Kaillera.

Things like these :
    • Since Kaillera currently does not support a function to compare the emulators settings, you need to do that yourself.
      That's important, so please read what should be the same on both clients :

      • The Game, the Region and the Version
      • The MemCard's (I recommend to use empty memcards while playing online)
      • The Bios Version
      • The Sound Plugin
      • The Sound Settings in ePSXe (Enabled XA sound, SPU IRQ Hack and so on)
      • The CDR Plugin (I recommend that both player use the ISO function)
      • If possible also the GPU Plugin

      If these settings aren't the same the game may work async.

    • ePSXe currently does not send any game-related informations to the Net-Plugin. This make it a bit hard for CyberPad, to know which game you are using.
      Since version 1.1, CyberPad uses a "hack", to get the game name directly from the emulators memory. Since this is just a "hack", I am not sure if it will work on all systems correctly, but it should atleast work on the most systems.

    • Don't use the pause function of ePSXe (ESC key), this may fuck up everything. :P

    The plugin itself currently (at the release date) does not have any KNOWN bugs, but a program without bugs isn't possible, so if you found something, please mail me.


Useful Links
Here you can find a small collection of useful links.

CyberPad WebSite :
  • http://cyberpad.ngemu.com
Kaillera WebSite :
  • http://www.kaillera.com
ePSXe WebSite :
  • http://www.epsxe.com
NGEmu.Com :
  • http://www.ngemu.com

My other psx-emulation projects :
  • PSX Emulation Cheater

      Emulate a GameShark-module for all PSX Emulators.

  • Blini!
      Compatibility-report-editor for Bleem!


Credits
A big thanks fly to the following people :
  • Christophe Thibault
  • Calb
  • Dragon¥en
  • The PSEmu Pro Team
  • Iczelion
  • i4get
  • Bobbi
... and everybody else I forgot.

And for sure you for using CyberPad.